Отключение поддержки протокола SSLv3

В среду (16 ноября 2016 года) произойдет отключение поддержки протокола SSLv3 при запросах в наше API.

Для дальнейшей корректной работы с нашим API вам необходимо убедиться, что на вашем сервере стоит следующее ПО: cURL версии 7.34.0 и выше.

Если версия cURL выше 7.34.0, а запросы продолжают возвращать код 0, вам необходимо принудительно переключить запросы на протокол TLSv1 или TLSv1.1, TLSv1.2

Для этого вы можете добавить в cURL запрос следующий параметр:

curl_setopt($curl, CURLOPT_SSLVERSION, CURL_SSLVERSION_TLSv1);

или

curl_setopt($curl, CURLOPT_SSLVERSION, 1); // если версия PHP < 5.5.

Подробней про доступные параметры можно прочитать в документации библиотеки cURL https://curl.haxx.se/libcurl/c/CURLOPT_SSLVERSION.html

В случае возникновения вопросов вы можете обратить за помощью написав нам на почту support@amocrm.ru

Еще есть вопросы? Отправить запрос
На базе технологии Zendesk